It shouldn't be possible to enter illegal characters into Link Name inputs
Summary: For example, when creating a new Property in CreateNewPropertyGadget
, you simply can't put illegal characters into its name. But if you then edit the Property later, you can enter them; you get an error when you try to submit. This should be more consistent.
Basically, right now the Link Name input is a simple TextInputGadget. It should instead:
- Be built around RxText.
- Have the Type ID as a data attribute.
- Detect when the Type is NameType.
- If so, apply
InputUtils.spaceNameFilter
(which should be renamed linkNameFilter).
- Also, we should refactor out the code in CreateNewPropertyGadget that hooks into blur and deletes any trailing spaces or dashes, and use that. (Probably becoming a new subclass of RxInput?)
This is only High, not Critical, because the back end now detects all errors and provides adequate feedback. But it would be better if we never got to the error in the first place.